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AboutAbout

Help authoring requires a lot of work especially if you need documentation in several different formats.
Helpinator does this work for you. You can concentrate on your content and leave all format handling to
Helpinator. Above that you can significantly reduce time spent on help authoring by using exclusive productivity
enhancements built in Helpinator. 

Basic featuresBasic features:

1. Produce CHM, PDF, RTF and Website from single source.

2. Multiple languages in one project file.

3. Easy-to-use topic editor with full set of features and integrated spell checker. Insert tables, images, flash
movies and etc

Helpinator 2.0 Manual

3



4. Built-in template engine allows different templates for different types of documentation.

5. Everything you need (text, images, templates, variables) to compile help files is inside one project file.

6. Library images. Use the same image in multiple topics without duplicating it.

7. Use text snippets to store blocks of text that appear is the same form in several topics.

8. Command-line utility to use from batch files.

9. Easy-to-use template builder.

10. Conditional compilation with the help from directives and variables.

11. To Do and task management.

Shared ImagesShared Images
Store images that you need to share across multiple topics under the "Images""Images" node. You can insert them
into topics by using pseudo-tag

{%IMG yourimage.ext%}

where yourimage.ext is the full name of the image. This tag will be replaced by corresponding image during
compilation.

Text Snippets.Text Snippets.
Store blocks of text that appear in the same form in multiple topics under "Snippets""Snippets" node.
Use pseudo-tag

{%yourmacro%}

to insert snippets into topics.
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What's New In Version 2.0What's New In Version 2.0

- Multiple Languages in one project file.
- Conditional compilation and Variable presets
- Image Editor with shapes
- Library images now can be shown in full size inside topic editor
- Template Builder
- To-Do for project and individual topics.
- Import and Export RTF and HTML files with project structure.
- Header and Footer for PDF output.
- PDF outline corresponding to topic structure
- Page numbers in Table of Contents in PDF documents.

How To BuyHow To Buy

To register Helpinator Professional:To register Helpinator Professional:

1. Follow this link to buy product:
https://www.plimus.com/jsp/buynow.jsp?contractId=1840026
2. Wait for the email with your registration code.
3. Select Main Menu->Help->About
4. Click "Register".
5. Enter registration information exactly as it is in registration confirmation email.

As a registered user you are eligible to:As a registered user you are eligible to:
1. One-year free updates (even major version updates).
2. Priority E-mail support.

SupportSupport

Send your questions to:

support@majormind.com

or visit support forum:

http://www.majormind.com/forum

Note that we provide priority email support only for registered users of Helpinator Professional.
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OverviewOverview

This topic contains brief information on:
1. Project
2. Templates
3. Images
4. Text Snippets
5. Variables
6. Multiple languages in one project file.

ProjectProject

Project stores all the data you need to compile documentation:
1. Topics in hierarchical order with separate text for different languages.
2. Templates. Both HTML and RTF are stored inside project file. You can use different templates for different
languages.
3. Library Images.
4. Text snippets.
5. Variables. 
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Project TitleProject Title - Title of this help file to show at the window caption.
Default TopicDefault Topic - topic to open by default when help file is opened without context id.
Default FontDefault Font - default font for the contents window.
LanguageLanguage - default project language.
Default HTML TemplateDefault HTML Template - HTML Template to assign to newly added topics within selected language. 
RTF TemplateRTF Template - RTF Template to use for PDF and RTF generation within selected language.
Auto Context IDAuto Context ID - auto generate context ids for new topics.
Auto IndexAuto Index - Auto generate help file index based on keywords you enter into the "Keywords" node of the
project tree.
PDF SettingsPDF Settings - Click this to open "PDF settings dialog".
VariablesVariables - Variables to use in your topics and templates. To put this variable into topic or template write
"{%yourvariable%}" where yourvariable is the name of the variable.

TemplatesTemplates

Templates are used to to customize appearance of your documentation.

1. HTML Templates. 1. HTML Templates. 
Use HTML Templates to change CHM file looks. Each page can have it's own HTML template. HTML
templates are divided into HTML and CSS parts. Use HTML to create topic page structure and CSS to
change layout.
Helpinator has built-in Template Builder so you don's even have to know HTML and CSS to create your own
template.

2. RTF Templates2. RTF Templates
RTF Templates are used to produce RTF and PDF files.

Read more about templates.

ImagesImages

Images in Helpinator are divided into 2 categories:

1. In-topic images.1. In-topic images. This images are inserted into WYSIWYG editor and belong to only one topic. To place
this image into another topic you need to create another copy of it in that topic. This images are considered
hard to change since you need to browse through all the topics when something in your program's interface
changes.

2. Images that are stored under "Images" node of the project.2. Images that are stored under "Images" node of the project. These images do not belong to any topic
and thus can be shared by several of them. To use a shared image inside a topic you need to place a
pseudo-tag like this:

{%IMG yourimage.ext%}

where yourimage.ext is a full name of the shared image with extension. During the compilation phase this
pseudo-tag would be replaced by the corresponding image. Alternatively you can insert library image without
pseudo-tags using topic editor context menu and it will look like in-topic image except that it will have a small
description at the top.

Shared images are easy to change. If you need to change an image you don't have to browse through topics
to find it's occurrences. Just replace it under "Images" node of the project.

Text SnippetsText Snippets

Snippets are named blocks of text that you can use in several topics. For example, when writing tutorials you
need repetitive lines of text like "Select Main Menu -> File -> Open". But when your main menu structure
changes and you rename menu "File" into something like "Project" you need to update all topics that
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describe actions associated with this menu. Instead of that you can create Snippets named "menufileopen"
with the text "Select Main Menu -> File -> Open" and use it whenever you need to reference this menu. Now
when your menu structure changes you only need to edit this snippet and recompile help file.

VariablesVariables

Variables are similar to text snippets but are for different purpose. The main differences are:
1. Variables can not have text formatting.
2. Variables can be used in templates.
3. Variables can be used to control compilation process.

There are 3 main groups of variables:
1. Global Variables. These variables have the same value for all languages.
2. Language-Specific variables. These variables have different values for every language in the project.
3. Variable Preset. Variables in preset have values specific to that preset.
4. Predefined variables. Values of predefined values depend on compile mode and cannot be changed by
user.
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Examples of Global Variables:
- Company name
- Software title
- Year of release
- Version

Examples of Language-Specific Variables:
- Localized Software Title

Examples of Variable Presets:
- Edition
- Software Title - for branding of your product.

Predefined Variables are:
- FORMAT - can be CHM, PDF, RTF, HTML
- Language - LangID of the current project language.

Presets can be used to control compilation process using Conditional Compilation.
For example you have two editions of your product - LITE and PRO, PRO edition has specific features that
LITE does not have and you don't want those topics in the help file of LITE edition. You can solve this problem
by having two different projects or you can use variable presets. Add two presets - PRO and LITE, and
EDITION variable to them. Now you can put line "EDITION='PRO'" into the "Condition" property of topics you
want to skip from LITE edition help file. At Compile time select "PRO" preset to compile help for PRO edition
and "LITE" preset to compile LITE edition help file. To learn more see "Conditional Compilation" topic.

Multiple LanguagesMultiple Languages

With Helpinator you can create documentation in different languages from the same project file. To add new
languages to the project click "plus" sign on the language bar:

Check as many languages as you like and click "OK".

Almost every item in the Helpinator project can be language-specific. For every language you can have
separate:
1. Topic content
2. Keywords
3. Variable values
4. Text snippets
5. RTF and HTML templates.

Library images are the same for all languages.

Note that you can not have different topic tree in different languages. Tree is always the same, only topic
titles change.

To select language you want to edit, select it in the language drop-down list on the language bar.
When you click "Compile" buttons currently selected language is used.
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How To...How To...

This topic covers some basic functions available in Helpinator.
You can learn how to:
Add Topic
Add Subtopic
Edit Topic
Insert Image
Insert Table
Insert Link To Another Topic
Insert Link To External Web Page
Compile Help
Assign Keywords
Import and Export
Add Several Topics

Add TopicAdd Topic

To add new topic select "Topics" node in the tree view and click "Add Item" button on the toolbar. You then
will be prompted for topic title.

Add SubtopicAdd Subtopic

To add subtopic or "child topic" first select a topic you want to add subtopic to. Click "Add Item" button on
the toolbar and enter new topic title.
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Edit TopicEdit Topic

To edit topic select it in the tree view. Topic Editor will appear at the right side of the Helpinator window. You
can enter text and use formatting options that are accessible from toolbar at the top.

Read more about topic editor...

{%IMG edittopic.png%}

Insert ImageInsert Image

You can add image to the topic by two ways:
1. Click "Picture" button on the topic editor toolbar and select image file name. This image will be "local"
topic image.

2. First add image to the "Images" node. This will make your image global or "library" and you will be able to
use it in multiple topics. When image is in the "library" place a pseudo-tag like
{%IMG yourimage.ext%} {%IMG yourimage.ext%} 
where you want this image to be. "yourimage.ext" is the name of your "library" image.

There's an alternate way to insert a Library Image. Place cursor into the topic editor where you need image to
be placed. Right-click, select "Insert Library Image" and select library image name. Image will be shown as it
is with header like "Lib img: <image name>". This is more WYSIWYG-style but image occupies more space
in editor than just a placeholder.

Insert TableInsert Table

To insert table click "Table" button on the toolbar. You then will be prompted for number of rows and columns.
Press "OK" and table will be inserted in the position of cursor.
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Insert Link To Another TopicInsert Link To Another Topic

To insert link to another topic select text that will become a link and click "Hypertext Link" button on the tool
bar.

In the "Insert Hyperlink" dialog select "Topic" page and select topic to link to in the tree. If you want to link to
an anchor inside that topic select it from the "Anchor" list.
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Insert Link To External Web PageInsert Link To External Web Page

To insert link to another topic select text that will become a link and click "Hypertext Link" button on the tool
bar.

In the "Insert Hyperlink" dialog select "Internet" page and enter URL or email.

Compile HelpCompile Help

To Compile help click on one of the toolbar buttons that are responsible for the specific format.

Helpinator 2.0 Manual

13



Compiled file (CHM, PDF or RTF) will be placed in the same directory where your project is. Browser-based
HTML help will be in "HTML" subfolder of the folder where your project resides.

To put compiled files into different location select "Compile All". Also this dialog lets you to compile several
formats at the same time and select variable preset for compilation.

Assign KeywordsAssign Keywords

You can assign keywords to topics by two ways:
1. Enter them into "Keywords" field of the topic editor. Separate individual keywords with commas.
2. Select keyword in the topic editor, right-click it and select "Add to keywords" from the context menu.

Helpinator also has "Auto Index" feature. All you need is to add keywords for each language into "Keywords"
section of project tree view. Then Helpinator will append keywords to topics automatically at compile time. To
enable "Auto Index" select Project root in the tree, select "General" tab and check "Auto Index" checkbox.

Import and ExportImport and Export

Helpinator can import and export RTF and HTML documents. You can import/export just files with topic
content or with some additional info like keywords and project structure. This allows easy communication
with external translation services. You can export RTF/HTML with project structure info, send this files to your
translator or use translation software, then import in back to another language keeping project structure.

To Import HTML and RTF do the following:

Helpinator 2.0 Manual

14



1. Select menu File->Import->Import RTF or Import HTML.
2. "Import" dialog appears.

3. Select folder where your files are located.
4. Select project language to import data to.
5. Select import mode - whether you want to import only files or project info is present too.
6. Click OK.

Export works just like Import.

Add Several TopicsAdd Several Topics

1. Click "Add several topics" button. "Add topics" windows appears.

2. Enter topic names with tabs showing their levels in the topic tree.

3. Click "OK"
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Edit TopicEdit Topic

{%IMG edittopic.png%}

Topic editor consists from two parts - editing tools on the top and topic properties at the bottom.

Topic PropertiesTopic Properties

There are four tabs with topic properties:
1. General

2. ToDo

3. Notes

4. HTML Template

GeneralGeneral

Topic nameTopic name - title of this topic
IDID - topic id
Context IDContext ID - numeric context id to associate with topic id.
KeywordsKeywords - comma-separated list of keywords.
ConditionCondition - expression to control topic inclusion for conditional compilation.

ToDoToDo

At this tab you can assign to-do items to the current topic. Each to-do items consists of Text, Priority and
Progress. To watch all to-do items in all topics select "Tasks" node in the project tree view.
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NotesNotes

Note is just plain text. You can write your future plans on this topic or any other free-form information.

HTML TemplateHTML Template

On this tab you can select what template to use for this topic on CHM and HTML compilation. You can use
project default template for selected language or specific template for this topic.

Topic Editor ToolbarsTopic Editor Toolbars

1 - Print Preview
2 - Print
3 - Cut
4 - Copy
5 - Paste
6 - Insert picture
7 - Insert hyperlink
8 - Insert named bookmark
9 - Insert horizontal line
10 - Insert page break
11 - Insert special symbol
12 - Insert flash movie
13 - Insert table
14 - Table Properties
15 - Merge Cells
16 - Split Cells
17 - Insert column before
18 - Insert column after
19 - Insert row before
20 - Insert row after
21 - Delete column
22 - Delete row

1 - Bold
2 - Italic
3 - Underline
4 - Strikeout
5 - Align text left
6 - Align text center
7 - Align text right
8 - Justify
9 - List
10 - Font color
11 - Background color
12 - Font name
13 - Font size
14 - Spell check
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Work With KeywordsWork With Keywords

Keywords are used to fill "Index" tab in the HTML Help Viewer. You can check "Auto Index" option in project
settings and leave all index generation work to Helpinator. Or you can create keywords manually from topic
editor or from Keyword Manager.

Keywords are highlighted with dotted blue line in topic editor.

From Topic EditorFrom Topic Editor

To edit keywords associated with the topic enter them into "Keywords" edit field and separate by commas.

You can add keyword to the list by selecting it in topic editor and clicking "Add To Keywords" option in the
context menu.

Manage KeywordsManage Keywords
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From this window you can:

- Add KeywordAdd Keyword. Click "Add" and enter new keyword.
- Delete KeywordDelete Keyword. Click "Delete" and confirm.
- Edit KeywordEdit Keyword. Click "Edit" and edit keyword.
- Create tree structure of keywordsCreate tree structure of keywords. Drag a keyword to the node you want this keyword to be child of.
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Work With Library ImagesWork With Library Images

This topic covers image handling with Helpinator.

Add ImageAdd Image

1. Select "Images" node.
2. Click "Add" button.
3. Select the image you with to add.

Delete ImageDelete Image
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1. Select "Images" node.
2. Click "Delete".
3. Confirm your action.

Rename ImageRename Image

1. Select "Images" node.
2. Click "Rename"
3. Enter new image file name with extension.

Insert Image PlaceholderInsert Image Placeholder

1. Select a topic in the tree.
2. Move a cursor to a place where you want image to be placed.
3. Enter pseudo-tag as follows:

{%IMG yourimage.ext%}

where yourimage.ext - is a full name of your image with extension.

Also you can insert library images in full-size. Place cursor where you want to library image to be, right-click,
select "Insert Library Image" and select an image from the list.

Image EditorImage Editor

Helpinator comes with simplistic image editor. With it's help you can add various shapes to your images and
screenshots. Shapes are stored as vector data but at compile time Helpinator converts them to raster
images.
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To activate Image Editor select image under "Images" node in the project tree view. Image editor tool bar is at
the top of image preview area. Now select Tools->Activate Editor.
From Tools Tools menu you also can:
- Extend Image canvas. This is useful when you need more place for shapes.
- Replace bitmap. Use this feature when you want to keep shapes but some interface elements on your
screen shot have changed.

Add New Empty ImageAdd New Empty Image

If you just need an image with shapes, e.g. some kind of flow chart, you can add new blank image to library.
Select "Images" node from the project tree view, right-click on it and select "New Image". "New Image" dialog
will appear. You can select image name, size and background color.
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Work With Text SnippetsWork With Text Snippets

Text SnippetsText Snippets are named blocks of text that you can use in several topics.

From this window you can:
1. Add Snippet
2. Delete Snippet
3. Rename Snippets

Subtopics:
Add Text Snippet
Delete Snippet
Insert Snippet Placeholder
Edit Snippet
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Add Text SnippetAdd Text Snippet

To add Include:
1. Select "Text Snippets" node.
2. Click "Add"
3. Enter name for your snippet.

Delete SnippetDelete Snippet

To delete include:
1. Select "Text Snippets" node.
2. Click "Delete"
3. Confirm deletion.

Insert Snippet PlaceholderInsert Snippet Placeholder

To insert snippet placeholder into a topic enter this pseudo tag:

{%yoursnippet%}

where yoursnipet - is the name of snippet to be placed here during compilation phase.

Edit SnippetEdit Snippet

To edit snippet select it under "Text Snippets" node and edit just like you edit a topic.
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Understanding TemplatesUnderstanding Templates

Templates are used to to customize appearance of your documentation.
Templates are stored inside project file. 
To use template you need to add it to project first. Read this to know how.
Some default templates are in the "templates" sub folder of Helpinator installation folder.

1. HTML Templates. 1. HTML Templates. 
Use HTML Templates to change CHM file and Web help looks. Each page can have it's own HTML template.
HTML templates are divided into HTML and CSS parts. Use HTML to create topic page structure and CSS to
change layout.
Templates use pseudo-tags to define layout. Pseudo-tags are lines of text in the format {%tagname%} where
tagname is the name of the tag to be used.
You can use the following pseudo-tags to fit topic inside template

TagTag DescriptionDescription
TITLE Title of the topic.
CONTENT Topic text.
PREVNEXTTOPIC Navigation links to previous and next topics. It Looks

like:
Previous | Next

NEXTTOPIC Link to the next topic.
PREVTOPIC Link to the previous topic.
BREADCRUMBS Path to the current topic. It contains links to the topics

that lead to the current topic.
For example:
About > Order > How To Purchase.

SEEALSO Links to related topics. Keywords assigned to the
current topic are used to create this list. If some
topics have the same keywords that the current topic
has then they will be in this list.
You need to specify title of this block. For example:
SEEALSO="Related Topics:"

Also you can use project's variables.
Predefined variables:

VariableVariable DescriptionDescription
COMPANYNAME Your software company.
YEAR Year of the release.
VERSION Release version.
PROGRAMNAME Software title.

2. RTF Templates2. RTF Templates
RTF Templates are used to produce RTF and PDF files. RTF Template consists of 3 pages:
- Front Page
- Contents Page
- Topic Page

Also RTF template has two additional areas for PDF output that you can change:
- Header
- Footer

Front page defines the looks of the first page of your document. It is recommended to use project variables to
customize it.

Contents Page is used to render contents of the document. It consists from lines like "LEVEL1 TEXT",
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"LEVEL2 TEXT" and so on. The number after "LEVEL" word identifies level of this entry. For example, if you
have a topic in your help file named "Main Topic" and a subtopic "Sub Topic" then style of the line "LEVEL1
TEXT" is used to render "Main Topic" entry and "LEVEL2 TEXT" to render "Subtopic".

Topic page doesn't allow much customization. You can only use "CONTENT" and "TITLE" pseudo-tags.

Header and Footer are only for PDF. Header and footer apply only for pages with content (e.g. except front
page). Beside project variables header and footer can have the following variables:
- {%PAGENUM%} - current page number.

RTF TemplatesRTF Templates

To AddAdd RTF template:
1. Select "RTF Templates" node.
2. Click "Add"
3. Browse to your rtf template file.
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To RenameRename RTF template:
1. Select "RTF Templates" node.
2. Click "Rename".
3. Edit template's name.

To DeleteDelete RTF Template:
1. Select "RTF Templates" node.
2. Click "Delete"
3. Confirm your choice.

HTML TemplatesHTML Templates

To AddAdd HTML template:
1. Select "HTML Templates" node.
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2. Click "Add"
3. Browse to your html template file. CSS file must have the same name, must be located in the same folder
as html file and .css extension.

To RenameRename HTML template:
1. Select "HTML Templates" node.
2. Click "Rename".
3. Edit template's name.

To DeleteDelete HTML Template:
1. Select "HTML Templates" node.
2. Click "Delete"
3. Confirm your choice.

Template BuilderTemplate Builder

If you do not have enough HTML knowledge to create your own template you can use "Template Builder"
feature:
1. Select "HTML Templates" node in project tree.
2. Right-click on it.
3. Select "Add Template Builder" from pop-up menu.
4. You will be prompted for a unique name of template. 
5. Template Builder window appear.
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Each template consists of the following parts:
• header
• breadcrumbs area (shows path to current topic with links)
• navigation (links to previous and next topics)
• content (where the topic content will be)
• see also (related topics list)
• footer

You can check each template part to appear/disappear from template. Click "Edit" to make change the way
template part appear. You can change:
• font
• background color
• border color, line style and width

Click "Switch to HTML" if you want to edit your template in normal HTML mode. Note that you can not revert
back to Template Builder from HTML.
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Click "Export" to export current template to HTML so you can import it to other Helpinator projects.
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Compile HelpCompile Help

Helpinator can produce documentation in the following formats:
1. CHM
2. PDF
3. RTF
4. Website.

CHMCHM

To compile CHM you need Microsoft HTML Help Workshop installed on your computer.

Click CHM button on the toolbar or select Tools->Compile CHM.
Helpinator creates CHM file with the same file name as your project and in the same directory.

RTFRTF

Click RTF button on the toolbar or select Tools->Compile RTF.
Helpinator creates RTF file with the same file name as your project and in the same directory.

PDFPDF

Click "PDF" button on the toolbar or select "Tools->Compile PDFTools->Compile PDF".
Helpinator creates PDF file with the same file name as your project and in the same directory.

You can change some aspects of PDF generation using PDF Settings dialog. You can call it by pressing 
"PDF Settings...""PDF Settings..." button in the project options window.

PDF Options.PDF Options.
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General Tab:General Tab:
AuthorAuthor - author of this document.
VersionVersion - version of this document.
SubjectSubject - subject of this document.
KeywordsKeywords - keywords, associated with this document.
CompressionCompression - select compression level.
ResolutionResolution - target document resolution, dot per inch.
Auto URLAuto URL - auto translate to urls text like "http://www.site.com"
Emulate Standard FontEmulate Standard Font - If the property is set to ON, "Arial", "Courier New" and "Times New Roman" will be
emulated via standard PDF fonts.
EMF Image as JPEGEMF Image as JPEG - convert metafiles to JPEG.
One PassOne Pass - slower generation, requires less memory.

Page Tab:Page Tab:
Left Margin, Top Margin, Right Margin, Bottom MarginsLeft Margin, Top Margin, Right Margin, Bottom Margins - page margins in inches.
Page LayoutPage Layout - determines pages of the document is rendered when opened.
OrientationOrientation - page orientation - portrait/landscape.
Page ModePage Mode - how the document looks when opened in a viewer application.
Paper SizePaper Size - printer size of the paper.

Protection:Protection:
Check "Enable ProtectionEnable Protection" to protect document.
Key LengthKey Length - encryption key length.
Owner PasswordOwner Password - password to allow document editing.
User PasswordUser Password - password to view document.

WebsiteWebsite

Click "Web" button on the toolbar or select "Tools->Compile WebsiteTools->Compile Website".
Helpinator create "html" folder in the directory where your project file is located and stores website in it. 

Compile AllCompile All

To compile all available help formats at once select Tools->Compile All or click on "Compile all formats"
button on the tool bar.

"Compile" dialog will appear. Check formats you want to compile and select paths to store compiles files to.
Or leave it with default values.
Check "Auto open" if you want all compiled files to open right after they are ready.

Conditional CompilationConditional Compilation

With Helpinator you are able not only able to generate help files in variety of formats and languages. You can
have as many different structures of content as you wish. This can be done using "Conditional Compilation".

Generally Conditional Compilation consists of two parts.

1. Topic inclusion conditions. Every topic has "Condition" property. At compile time Helpinator evaluates
expression in this property and if result is "False" then this topic is skipped.
2. Conditional directives inside topic content. You can use directives with expressions to skip parts of content
at compile time. There are two conditional directives at the moment:
• If <expression>. This directive allows you to skip part of the topic content on compile time if

<expression> results in False.
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• Comment. This directive allows you to skip part of the content unconditionally. This is useful to put some
remarks or comments into topic content.

Examples:

Note that at this moment directives can not be nested.Note that at this moment directives can not be nested.

To control compilation you need to use variables. See Variables topic to learn more about variables and their
types.
The most effective way to alter resulting help files with conditional compilation is to use variable presets. You
can select preset from "Compile All" dialog or select it using parameters of command-line utility. The latter
approach makes branding of your products easy as a snap.

Command Line UtilityCommand Line Utility

Helpinator comes with command-line compiler chelpinator.exechelpinator.exe that you can use in batch files.
It has the following parameters:

chelpinator.exe <format> <outputfileorfolder> [/v<variables.ini>] [/lang:LangID] <projectfile>

<format> (required) - specifies output format. Can have the following values:
- /chm - for CHM format
- /rtf - for RTF format
- /pdf - for PDF format
- /html - for browser-based html help.

<outputfileorfolder> (required) - specifies full output folder or file name. Filename is for CHM, PDF and RTF
formats and folder is for HTML format.

/v<variables.ini> (optional) - you can override values of project variables using this switch. Create a file with
variables you want to override in the form:
VARIABLE=VALUE
For example:
VERSION=1.5.1

If the text after "/v" has no extension it is treated as variable preset name and the corresponding preset is
selected.

/lang:LangID (optional) - one of project languages. Specify this parameter if you want to generate
documentation for one of the languages in the project. LangID is required. You can find possible values in the
following table:

LangID Language
0436 Afrikaans
041c Albanian
1401 Arabic (Algeria)
3c01 Arabic (Bahrain)
0c01 Arabic (Egypt)
0801 Arabic (Iraq)
2c01 Arabic (Jordan)
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3401 Arabic (Kuwait)
3001 Arabic (Lebanon)
1001 Arabic (Libya)
1801 Arabic (Morocco)
2001 Arabic (Oman)
4001 Arabic (Qatar)
0401 Arabic (Saudi Arabia)
2801 Arabic (Syria)
1c01 Arabic (Tunisia)
3801 Arabic (U.A.E.)
2401 Arabic (Yemen)
042b Armenian
082c Azeri (Cyrillic)
042c Azeri (Latin)
042d Basque
0423 Belarusian
141a Bosnian (Latin, Bosnia and Herzegovina)
0402 Bulgarian
0403 Catalan
0c04 Chinese (Hong Kong S.A.R.)
1404 Chinese (Macau S.A.R.)
0804 Chinese (PRC)
1004 Chinese (Singapore)
0404 Chinese (Taiwan)
041a Croatian
101a Croatian (Bosnia and Herzegovina)
0405 Czech
0406 Danish
0465 Divehi
0813 Dutch (Belgium)
0413 Dutch (Netherlands)
0c09 English (Australia)
2809 English (Belize)
1009 English (Canada)
2409 English (Caribbean)
1809 English (Ireland)
2009 English (Jamaica)
1409 English (New Zealand)
3409 English (Philippines)
1c09 English (South Africa)
2c09 English (Trinidad)
0809 English (United Kingdom)
0409 English (United States)
3009 English (Zimbabwe)
0425 Estonian
042f FYRO Macedonian
0438 Faeroese
0429 Farsi
040b Finnish
080c French (Belgium)
0c0c French (Canada)
040c French (France)
140c French (Luxembourg)
180c French (Monaco)
100c French (Switzerland)
0456 Galician
0437 Georgian
0c07 German (Austria)
0407 German (Germany)
1407 German (Liechtenstein)
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1007 German (Luxembourg)
0807 German (Switzerland)
0408 Greek
0447 Gujarati
040d Hebrew
0439 Hindi
040e Hungarian
040f Icelandic
0421 Indonesian
0410 Italian (Italy)
0810 Italian (Switzerland)
0411 Japanese
044b Kannada
043f Kazakh
0457 Konkani
0412 Korean
0440 Kyrgyz (Cyrillic)
0426 Latvian
0427 Lithuanian
083e Malay (Brunei Darussalam)
043e Malay (Malaysia)
043a Maltese
0481 Maori
044e Marathi
0450 Mongolian (Cyrillic)
046c Northern Sotho
0414 Norwegian (Bokmal)
0814 Norwegian (Nynorsk)
0415 Polish
0416 Portuguese (Brazil)
0816 Portuguese (Portugal)
0446 Punjabi
046b Quechua (Bolivia)
086b Quechua (Ecuador)
0c6b Quechua (Peru)
0418 Romanian
0419 Russian
243B Sami, Inari (Finland)
103b Sami, Lule (Norway)
143b Sami, Lule (Sweden)
0c3b Sami, Northern (Finland)
043b Sami, Northern (Norway)
083b Sami, Northern (Sweden)
203b Sami, Skolt (Finland)
183b Sami, Southern (Norway)
1c3b Sami, Southern (Sweden)
044f Sanskrit
0c1a Serbian (Cyrillic)
1c1a Serbian (Cyrillic, Bosnia and Herzegovina)
081a Serbian (Latin)
181a Serbian (Latin, Bosnia and Herzegovina)
041b Slovak
0424 Slovenian
2c0a Spanish (Argentina)
400a Spanish (Bolivia)
340a Spanish (Chile)
240a Spanish (Colombia)
140a Spanish (Costa Rica)
1c0a Spanish (Dominican Republic)
300a Spanish (Ecuador)
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440a Spanish (El Salvador)
100a Spanish (Guatemala)
480a Spanish (Honduras)
0c0a Spanish (International Sort)
080a Spanish (Mexico)
4c0a Spanish (Nicaragua)
180a Spanish (Panama)
3c0a Spanish (Paraguay)
280a Spanish (Peru)
500a Spanish (Puerto Rico)
040a Spanish (Traditional Sort)
380a Spanish (Uruguay)
200a Spanish (Venezuela)
0441 Swahili
041d Swedish
081d Swedish (Finland)
045a Syriac
0449 Tamil
0444 Tatar
044a Telugu
041e Thai
0432 Tswana
041f Turkish
0422 Ukrainian
0420 Urdu
0843 Uzbek (Cyrillic)
0443 Uzbek (Latin)
042a Vietnamese
0452 Welsh
0434 Xhosa
0435 Zulu

<projectfile> (required) - full path to the Helpinator project you are about to compile.

Example.Example.
Suppose path to your project is C:\Project\Help\myproject.hgu.
You need to compile PDF help from it and place it into C:\PDF folder. You have variable preset "pro" and want
to use it. You have several languages in the project and you want to use "English (United States)"
You can use the following command line to do that:

chelpinator.exe /pdf /vpro /lang:0409 C:\PDF\myproject.pdf C:\Project\Help\myproject.hgu
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