How to use “REimport” feature

Version 3.11.4 introduces new feature called “REimport”. What is it for?

Let’s consider this scenario  – you start your help project by importing html/rtf/txt files that you already have as documentation, do some alterations, formatting, screenshots, etc and all over sudden source documents change and you have two options – copy/paste them manually or import all documents and start your help project from scratch. Sad.

But not any more. Now you can selectively import changed documents into existing topics.

First, scroll the project tree down to the “Tools” node and select “REimport” sub node.

reimport1

 

If your documents were imported with version 3.11.4 and above, “File name” and “Path” columns should be filled with paths of source documents. In our case we have old project with blank columns. Helpinator will remember selected file names for future use.

First of all check topics to import with check boxes in the first column. Then select file names to import – double click the cell next to the topic title and select file name in the dialog that appears.

When everything is set and done click “Run” button on the toolbar below “REimport” title.

How to adapt existing RTF/PDF/Print templates to new topic title styles

Version 3.11.3 allows you to define different styles for topic titles according to their levels in the topic tree. Say, you want to have topic titles of level 1 in bold, level 2 in italic and level 3 underlined – now all that is possible.

Old versions allow only one style, it is defined by formatting of pseudotag {%TITLE%}. That should continue to work, but if you want to use new feature of topic title styles you need to upgrade your template. However it is very easy to do. The overall idea remains the same, but pseudotags are now numbered to reflect levels. E.g. {%TITLE1%} for the first level, {%TITLE2%} for the second and so on. You can create a new blank project with version 3.11.3 and open “default.rtf” node to see how it is done. The image below shows how it should look like (you can set your own styles of course).

rtftitles

How to change order and hierarchy of topics quickly

Version 3.11.3 introduces new feature called “Advanced rearrange”. It allows to quickly change order, titles and hierarchy of multiple topics at once. Normally Helpinator allows to change order of topics and their position in the topic tree by dragging and dropping topics in the topic manager. It is good for a topic or two but is very uncomfortable and time-consuming when you need to change places of several topics in a large project (say, after mass-importing html/rtf files).

To activate this feature select “Topics” node and click the button shown on the image below.

 

rearrange-button

 

It opens up “Advanced rearrange” window. This window is a simple plain text editor with a topics tree converted to it’s plain text representation. Each line has a topic title and topic id in brackets at the end of the line. If a topic is a subtopic, it’s line starts with a TAB (one for level 1 subtopics, two TABS for level 2 and so on).

 

advanced-rearrange

 

What you can do here:

  1. Cut/Paste topics en masse. Select several lines with your mouse or Shift+cursor, click Ctrl+X to cut them, place cursor into their new location and click “Ctrl+V” to paste.
  2. Change levels – just insert/remove TABs at the beginning of the line. To move several topics to another level (e.g. to insert TAB into several lines) select them as told above and click “Increase Level”. This will insert TABs into several lines at once. “Decrease level” works the same way.
  3. Rename topics. It’s OK to change topic titles as long as you keep ID part at the end of each line intact.

What you CAN’T do:

  1. Change or delete topic IDs. They are used for identification, so it will cause an error.
  2. Delete topics – to delete topics please use corresponding command of the topic manager. Deleting topics here will cause an error.
  3. Add new topics – the same as with “Delete topics” issue, use “Add topics” command from the topic manager.

How To Add Templates for New Formats to Existing Projects

By default projects creates with earlier versions of Helpinator has empty fields for the new formats and no specialized templates in them (For EPUB, MOBI and JavaHelp for example). So you need to add them manually.

First of all select “HTML-based templates” node in the project tree view and click “+” sign. “Add Template” dialog appears.

Add Template

 

Note the list of compatible formats under the “Built-in” templates drop-down list. When you select a template it shows what formats you can compile using it. Say, we need to add a template for EPUB format, so we select “epubmobi-default” template and click “OK”. Helpinator adds this template to the list of available templates.

Now you can select this template in the project options, “Templates” tab.

Helpinator 3.9 - Untitled (Unregistered)

Helpinator Copy Code Button

Q: Why there’s no “copy code” button for code snippets in CHM and WebHelp?

A: Incorporating “copy code” button requires some non-js code, Flash in particular, and that will make your CHM help files completely unusable because of security settings users may have. To copy a code snippet content from CHM file just double click it to select it entirely and click Ctrl+C.

How to Prototype Help Project Quickly

Helpinator allows you to build new help project in seconds. Here’s how:

1. Add several topics at once. You can create all project structure using simple plain text format. Use “tab” to identify levels.

addtopics

Add Topics

2. Add images. When you add images to Helpinator’s image library you can check option to add new topics with added images.

 

Add Images

 

3. Add topics as you capture new images. The same as above but using Screenshot tool.

4. Import existing “readme.txt”, “license.txt”, “gettingstarted.doc” and other documents that already exist in your project using Import Tools.

How to Add Annotations to Screenshots

Helpinator’s Image Library allows you to add various shapes with text and arrows to your screenshots, making it easy to describe program UI. To enable it, first select image in the tree view, then select “Tools->Activate Shape Editor”. Then you should select style for the shapes, default is “Red and Yellow”, meaning red lines and arrows with yellow background. You can read more on how to create styles.

image

 

To add new shape:

1. Select it on the toolbar

2. Click anywhere on the image where you want to place it.

How to Capture and REcapture screenshots in Helpinator

Helpinator allows you to capture screenshots of active windows with part of their background. Image Library serves as a storage for screenshots. There you can add annotation to screenshots and create clones. You can also assign category and automatically create topics for captured screenshots.

 

capture

 

Mode – select what you want to do – capture new image or recapture image that already exists in the library.

If you choose to capture new image you have to specify File name format and category for image. You can use several predefined placeholders:

Name Description
WINCAP Caption of the captured window
EXT Extension of the image format (see below)
HOUR Current hour
MIN Current minute
SEC Current second

 

If you choose to REcapture image you need to specify it in the drop-down list. Only background will be replaced, shapes will remain the same. You can use this trick to update cloned images easily. Here’s an article with detailed instructions:

http://www.helpinator.com/blog/2011/08/26/why-you-should-use-cloned-images/ 

 

– “Image Format” – specifies image format to store images to. You can select between PNG, BMP, JPEG and GIF.

– “Create topic” – if this option is checked then right after a window is stored to the library Helpinator creates topic with the same name containing captured image.

– “Append to topic” – if this option is checked and topic is selected from the drop-down list, Helpinator adds captured image to the end of the topic.

– “Background width” – specify what part of the active window background to capture along with the window itself. For example, if set to 30 pixels, then Helpinator will capture active window and surroundings with 30 pixels to the left, right, top and bottom. Set to 0 if you don’t want to capture background.

– “Background Effect” – select effect to apply to the background of the window. You can select from Blur, Darken, Pixelate and so on.

– “Drop shadow” – check this if you want active window to have a shadow on the background.

All this options combined allow you to take screenshots like this:

image

– “Hotkey” – select hotkey to trigger screen capture. Default is “Ctrl-Alt-S”

To start capturing images click on “Start” button.

How to Import Existing Documentation to Helpinator

Basically there are two ways to do it:

1. Using “Convert to H3 project” tool.

2. Using “File->Import files…” command.

Convert to H3 project

This tool is under "Helpinator” start menu group. When you run it dialog like this appears:

Convert to Helpinator 3 project

 

Source type – select type of the source files here. You can import:

1. Old Helpinator project

2. Compiled CHM file (if you don’t have the source for it).

3. HTML Help compiler project – if you were authoring CHM files using standard Microsoft tool – Help Workshop

4. RTF/HTML/TXT/DOC files – import variety of text file formats, from selected folder. To Import DOC files you need to have Microsoft Word installed.

 

Source – path to the source files or directory with source files (in case of source type #4).

Destination type – select type of Helpinator project to create. Single-file project stores all data inside one zip-compatible project file. “Multiple files” mode is better if you use come kind of VCS system in your project.

Destination – path to destination project. A filename or a directory path, in case of destination type #2.

Language – select default language for the project with imported data.

 

Click “Run” to start conversion. After it’s done you’ll be able to open destination project in Helpinator.

 

File->Import Files

 

This command acts identically to the “ RTF/HTML/TXT/DOC ” option from above, but is more useful to import files into existing projects. Select path to the directory with files to import and click “OK”.

Upgrading CHM\Web Help templates to support “Glossary”

You will have to add several lines of CSS code to your template for “Glossary” to work correctly.

1. Start new Helpinator project, select default templates

2. Select CHM\Web Help templates in the project tree view

3. Select “default.css”, browse to the end of it.

4. Copy the following code:

.glos_letter {
font-size: 12pt;
        font-weight: bold;       
        margin-top: 10px;
}

.glos_term {
        font-weight: bold;
        margin-top: 10px;                  
}

5. Open your project, select “.css” files of your templates and paste the code there.