Helpinator on BitsDuJour Today

Don’t miss it! One day only Professional Edition 60% off!

http://www.bitsdujour.com/software/helpinator/

Image Tools

Version 3.6.3 adds new feature: “Image Tools”. It is under the “Tools” node in the project tree view.

imagetools-tree

For now it contains only one tool: “Move Images To The Library”. This tool allows you to move all embedded topic images to the image library, optionally converting them to the desired format (PNG recommended).

image-tools

 

Later we will add more tools like “Resize images”, “Unclone” and more.

How to Prototype Help Project Quickly

Helpinator allows you to build new help project in seconds. Here’s how:

1. Add several topics at once. You can create all project structure using simple plain text format. Use “tab” to identify levels.

addtopics

Add Topics

2. Add images. When you add images to Helpinator’s image library you can check option to add new topics with added images.

 

Add Images

 

3. Add topics as you capture new images. The same as above but using Screenshot tool.

4. Import existing “readme.txt”, “license.txt”, “gettingstarted.doc” and other documents that already exist in your project using Import Tools.

How to Add Annotations to Screenshots

Helpinator’s Image Library allows you to add various shapes with text and arrows to your screenshots, making it easy to describe program UI. To enable it, first select image in the tree view, then select “Tools->Activate Shape Editor”. Then you should select style for the shapes, default is “Red and Yellow”, meaning red lines and arrows with yellow background. You can read more on how to create styles.

image

 

To add new shape:

1. Select it on the toolbar

2. Click anywhere on the image where you want to place it.

How to Capture and REcapture screenshots in Helpinator

Helpinator allows you to capture screenshots of active windows with part of their background. Image Library serves as a storage for screenshots. There you can add annotation to screenshots and create clones. You can also assign category and automatically create topics for captured screenshots.

 

capture

 

Mode – select what you want to do – capture new image or recapture image that already exists in the library.

If you choose to capture new image you have to specify File name format and category for image. You can use several predefined placeholders:

Name Description
WINCAP Caption of the captured window
EXT Extension of the image format (see below)
HOUR Current hour
MIN Current minute
SEC Current second

 

If you choose to REcapture image you need to specify it in the drop-down list. Only background will be replaced, shapes will remain the same. You can use this trick to update cloned images easily. Here’s an article with detailed instructions:

http://www.helpinator.com/blog/2011/08/26/why-you-should-use-cloned-images/ 

 

– “Image Format” – specifies image format to store images to. You can select between PNG, BMP, JPEG and GIF.

– “Create topic” – if this option is checked then right after a window is stored to the library Helpinator creates topic with the same name containing captured image.

– “Append to topic” – if this option is checked and topic is selected from the drop-down list, Helpinator adds captured image to the end of the topic.

– “Background width” – specify what part of the active window background to capture along with the window itself. For example, if set to 30 pixels, then Helpinator will capture active window and surroundings with 30 pixels to the left, right, top and bottom. Set to 0 if you don’t want to capture background.

– “Background Effect” – select effect to apply to the background of the window. You can select from Blur, Darken, Pixelate and so on.

– “Drop shadow” – check this if you want active window to have a shadow on the background.

All this options combined allow you to take screenshots like this:

image

– “Hotkey” – select hotkey to trigger screen capture. Default is “Ctrl-Alt-S”

To start capturing images click on “Start” button.

How to Import Existing Documentation to Helpinator

Basically there are two ways to do it:

1. Using “Convert to H3 project” tool.

2. Using “File->Import files…” command.

Convert to H3 project

This tool is under "Helpinator” start menu group. When you run it dialog like this appears:

Convert to Helpinator 3 project

 

Source type – select type of the source files here. You can import:

1. Old Helpinator project

2. Compiled CHM file (if you don’t have the source for it).

3. HTML Help compiler project – if you were authoring CHM files using standard Microsoft tool – Help Workshop

4. RTF/HTML/TXT/DOC files – import variety of text file formats, from selected folder. To Import DOC files you need to have Microsoft Word installed.

 

Source – path to the source files or directory with source files (in case of source type #4).

Destination type – select type of Helpinator project to create. Single-file project stores all data inside one zip-compatible project file. “Multiple files” mode is better if you use come kind of VCS system in your project.

Destination – path to destination project. A filename or a directory path, in case of destination type #2.

Language – select default language for the project with imported data.

 

Click “Run” to start conversion. After it’s done you’ll be able to open destination project in Helpinator.

 

File->Import Files

 

This command acts identically to the “ RTF/HTML/TXT/DOC ” option from above, but is more useful to import files into existing projects. Select path to the directory with files to import and click “OK”.